Su.pr for Wordpress requires WordPress 2.5 or a more recent version. Please update your WordPress version!